Jump to content
  • Buscar en
    • Más opciones...
    Encontrar resultados que contengan...
    Encontrar resultados en...

Archivado

Este tema ahora está archivado y cerrado a otras respuestas.

Jaco

Como hacer funcionar Bioshock en Windows 7

Publicaciones recomendadas

Jaco Sir Alonne

Publicado
vida restante: 100%
Llevo 2 meses investigando el tema, desde que cambié WIndows XP por 7 el juego no se ejecutaba, al intentar iniciarlo aparecía el logo de Bioshock y la aplicación no arrancaba. En el SAT de 2KGames me dieron varias soluciones y ninguna funcionó, al final se desentendieron del tema. Cuando por fin conseguí que arrancara lo hacía sin sonido, y hoy he logrado que vaya todo bien (por ahora). Ahí van los pasos que seguí, por si le sirven a alguien en mi misma situación (hubiera matado por estas soluciones hace 1 mes):

Desinstalar Open AL

Instalar DirectX End-User Runtimes (August 2009) (web de MS)

Acceso directo con -nointro después de las comillas del destino (...Bioshock.exe" -no intro)

En Default.ini en la carpeta del juego tiene que aparecer

[Engine.Engine]
UsePerforce=1
GameDriverClassName=ShockGame.ShockGameDriver
RenderDevice=D3DDrv.D3DRenderDevice
AudioDevice=FMODAudio.FMODAudioSubsystem
AudioDevice_Xenon=FMODAudio.FMODAudioSubsystem

Acceso directo y ejecutable del juego deben funcionar en modo de compatibilidad con Windows Vista

Panel de control - Hardware -Admin disp de audio - Grabar - Click dcho - Mostrar disp deshabilitados - Click dcho en Stereo Mix - Activar

--------------------------------------------------

NO NECESARIO SIEMPRE:

Edit your default.ini. Put a semi-colon in front of AudioDevice=FMODAudio.FMODAudioSubsystem, and add the following line right after it:
AudioDevice=D3DDrv.D3DAudioDevice
After edits, that part of the config file should look like this:
;AudioDevice=FMODAudio.FMODAudioSubsystem
AudioDevice=D3DDrv.D3DAudioDevice

Espero que os sirva o que no os haga falta para disfrutar de este juegazo.

Un saludo.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

BanshhE Ornstein y Smough

Publicado
vida restante: 100%
Tengo windows 7 en el portatil y el Bioshock no me dió problemas para instalarlo ni para jugarlo.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Jaco Sir Alonne

Publicado
vida restante: 100%
Enhorabuena, a mí me ha matado instalarlo, y como a mí a un montón de gente. Creo que tiene que ver con usar una tarjeta de sonido integrada en placa Realtek y actualizar el juego a la versión 1.1, que no se llevan bien

Disfruta de esta obra de arte.

Un saludo.

PD: es recomendable también actualizar la tarjeta de sonido Realtek con los ultimos drivers.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Raziel_ Super Meat Boy

Publicado
vida restante: 100%
venía a decirle lo mismo XD parece ser que es un problema generalizado, pero a otros tantos si que les ha funcionado sin problemas.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

andy103 Diosas de Oro

Publicado
vida restante: 100%
una pregunta, que es el "open al", donde se encuentra y como lo desinstalo?? :?(bueno, eso son tres preguntas :) )
y otra cosa, como se cambia eso del acceso directo? es que yo he probado de cambiarlo pero no me deja; me dice que no existe esa localizacion o algo asi

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Jaco Sir Alonne

Publicado
vida restante: 100%
Es una aplicacíon que puedes desinstalar en Panel de control - Desinstalar un programa. No sé para qué sirve, a mí creo que se me instaló al instalar otro juego (osea que a lo mejor tú no lo tienes) y no lo eché de menos al desinstalarlo.

El acceso directo lo creas con clik derecho en el archivo ejecutable del juego - Enviar a escritoro (crear acceso directo). Luego en el escritorio click derecho en el acceso directo y en Propiedades -Destino incluyes la coletilla -no intro al final (después de las comillas y un espacio).

Espero que te sirva.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

andy103 Diosas de Oro

Publicado
vida restante: 100%
Gracias, pero igualmente no me funciona, es que mi problema es que cuando empiezo una partida nueva se me queda colgado en la pantalla de "cargando". Si me pudieras dar alguna solucion para eso te estaria muy agradecido. Gracias de todos modos.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

andy103 Diosas de Oro

Publicado
vida restante: 100%
Vale, ya me funciona, pero despues del video en el que se ve un hombre en un avion, no se oye nada. ¿Me puedes ayudar, por favor?
P.D.: He hecho todo lo que pone aqui.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Jaco Sir Alonne

Publicado
vida restante: 100%
Chico, lo siento, pero lo que he escrito es todo lo que he encontrado y probado para hacerlo funcionar todo bien. Ese problema de no tener sonido también me pasó, y lo resolví con alguna de las cosas que escribí al principio. Asegúrate de actualizar los drivers de la tarjeta de sonido y prueba con lo que propongo bajo el epígrafe NO SIEMPRE.

Llegué a la conclusión de que los errores son casi aleatorios, a lo mejor reinicias el ordenador y funciona bien. Prueba con las posibilidades que te propongo. Ahí está la verdad (eso espero).

Un saludo.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

andy103 Diosas de Oro

Publicado
vida restante: 100%
Bueno, pues ya probaré a reiniciar el ordenador o buscaré alguna manera para que funcione. Si lo consigo, ya te lo diré. Gracias de todas maneras.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

RASKOLNIKOV Caballero Esclavo Gael

Publicado
vida restante: 100%
En mi caso la solución ha sido actualizar los drivers de sonido (realtek) pero como por lo visto hay multitud de problemas diferentes creo que este hilo de los foros de Steam puede ser útil:

http://forums.steamp...highlight=start

Esta en inglés y es conveniente leerse todo el hilo. Como lo mas probable es que sea un problema con el sonido, lo primero que debéis hacer es modificar el acceso directo poniendo -nosound. Si el juego arranca ya sabéis que efectivamente era el sonido. A partir de ahí y dependiendo de cual sea vuestra tarjeta de audio pues seguís una solución u otra.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Felipeee Methuselah

Publicado
vida restante: 100%
Jaco por favor te pido q me ayudes no encuentro solucion yo instalo el jeugo y toda va bien .. termina de instalarse y cuando abroo el aceso directo para jugar me sale el cartel del bioshock y despues una pantalla negra q solo se puede quitar cn control alt y supr..
Mira este link mi pc soporta todo hasta el audio q pide nose q sera por favor ayudame
Gracias
PD: http://cyri.systemre...I/analysis.aspx

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

RASKOLNIKOV Caballero Esclavo Gael

Publicado
vida restante: 100%
Modifica el acceso directo como he dicho en mi mensaje anterior poniendo -nosound. Si arranca sin problemas pero sin sonido es que tienes un problemas con tus drivers de la tarjeta de sonido. Hasta ahora la gran mayoría de problemas están relacionados con el sonido. Si tienes Windows 7 podrías optar por actualizarlos o si sigue dando problemas por desinstalarlos y dejar que Windows instale los suyos. Es algo que hará automaticamente sin que tengas que intervenir.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Onix212 Humano

Publicado
vida restante: 100%

Llevo 2 meses investigando el tema, desde que cambié WIndows XP por 7 el juego no se ejecutaba, al intentar iniciarlo aparecía el logo de Bioshock y la aplicación no arrancaba. En el SAT de 2KGames me dieron varias soluciones y ninguna funcionó, al final se desentendieron del tema. Cuando por fin conseguí que arrancara lo hacía sin sonido, y hoy he logrado que vaya todo bien (por ahora). Ahí van los pasos que seguí, por si le sirven a alguien en mi misma situación (hubiera matado por estas soluciones hace 1 mes):

 

Desinstalar Open AL

 

Instalar DirectX End-User Runtimes (August 2009) (web de MS)

 

Acceso directo con -nointro después de las comillas del destino (...Bioshock.exe" -no intro)

 

En Default.ini en la carpeta del juego tiene que aparecer

 

[Engine.Engine]

UsePerforce=1

GameDriverClassName=ShockGame.ShockGameDriver

RenderDevice=D3DDrv.D3DRenderDevice

AudioDevice=FMODAudio.FMODAudioSubsystem

AudioDevice_Xenon=FMODAudio.FMODAudioSubsystem

 

Acceso directo y ejecutable del juego deben funcionar en modo de compatibilidad con Windows Vista

 

Panel de control - Hardware -Admin disp de audio - Grabar - Click dcho - Mostrar disp deshabilitados - Click dcho en Stereo Mix - Activar

 

--------------------------------------------------

 

NO NECESARIO SIEMPRE:

 

Edit your default.ini. Put a semi-colon in front of AudioDevice=FMODAudio.FMODAudioSubsystem, and add the following line right after it:

AudioDevice=D3DDrv.D3DAudioDevice

After edits, that part of the config file should look like this:

;AudioDevice=FMODAudio.FMODAudioSubsystem

AudioDevice=D3DDrv.D3DAudioDevice

 

Espero que os sirva o que no os haga falta para disfrutar de este juegazo.

 

Un saludo.

 

 

 

 

---¡¡¡ERES EL PUTO AMO TIO!!! ME OCURRÍA LO MISMO Y ME ESTABA VOLVIENDO LOCO.

AHORA ME FUNCIONA PERFECTAMENTE.

GRACIAS JACO!!!!!!!!!!!!!!!!!!!!!!!!!!!!

TÚ SÍ QUE SABES.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web
Guest
Este tema está cerrado a nuevas respuestas.

  • Explorando recientemente

    No hay usuarios registrados viendo esta página.

  • Crear nuevo...